httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Erenkrantz <>
Subject Re: mod_disk_cache directives naming convention
Date Thu, 07 Oct 2004 19:12:57 GMT
--On Thursday, October 7, 2004 12:13 PM -0600 Jean-Jacques Clar 
<> wrote:

> I won't probably agree if we use 'Waboozle', and I suggest that the
> description
> should with the name of the module like MemCache* and DiskCache* to
> make it easier for related directives to be grouped together (sorted).

I'd really prefer for all caching directives to be under Cache* so that the 
alphabetical ordering of the directives that we generate in our docs group 
them together.  Using MemCache* and DiskCache* instead of CacheMem* and 
CacheDisk* sort of blow that away.

(However, I won't fight this too hard, but just want to make my preference 

>> If we go through the process of renaming the directives (and I'm +1 to
>> making  it consistent per my first paragraph), I'd like to see us toss all
>> of the  directives we don't implement.
> My only worry there is that they will disappear forever instead of always
> annoying us every time we open the c file or look at the doc page.

If we truly mean for it to be out of experimental, then it shouldn't have any 
no-op directives.  That's exceedingly bad form, IMHO.

>> BTW, are you volunteering to take the lead on this?  ;-)  -- justin
> Yes with pleasure,
> this is why I started the debate.

Yay!  -- justin

View raw message