httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: segfault in worker mpm
Date Mon, 04 Oct 2004 00:02:31 GMT
Stas Bekman wrote:
> Cliff Woolley wrote:
> 
>> On Sun, 3 Oct 2004, Stas Bekman wrote:
>>
>>
>>> modperl-2.0 'make test' running under worker mpm (linux) always fails in
>>> t/filter/both_str_req_add.t and dumps core:
>>>
>>> #0  0xffffe410 in ?? ()
>>> (gdb) bt
>>> #0  0xffffe410 in ?? ()
>>> #1  0xbfffeff8 in ?? ()
>>> #2  0x00000001 in ?? ()
>>> #3  0xbfffeff7 in ?? ()
>>> #4  0x4030536b in __read_nocancel () from /lib/tls/libpthread.so.0
>>> #5  0x080e03c3 in ap_mpm_pod_check (pod=0x817b250) at pod.c:53
>>
>>
>>
>> My only guess of things to check out right off hand: Is the pipe that's
>> being read from still a valid fd?  (Maybe it somehow got closed elsewhere
>> by some other thread accidentally?  Such things have happened before...)
> 
> 
> I don't work with any pipes explicitly. This test just runs a few input 
> and output filters, all using bucket brigades API. The problem is that I 
> can't reproduce it as well,

s/as well/at will/

> other than running some 100 tests before 
> this happens, so I'm not sure how to debug that. So I was hoping that 
> someone has encountered this problem before and knew how to deal with that.


-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

Mime
View raw message