httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Glenn Strauss <>
Subject Re: mod_disk_cache directives naming convention
Date Thu, 07 Oct 2004 22:32:04 GMT
On Thu, Oct 07, 2004 at 12:12:57PM -0700, Justin Erenkrantz wrote:
> --On Thursday, October 7, 2004 12:13 PM -0600 Jean-Jacques Clar 
> <> wrote:
> >I won't probably agree if we use 'Waboozle', and I suggest that the
> >description
> >should with the name of the module like MemCache* and DiskCache* to
> >make it easier for related directives to be grouped together (sorted).
> I'd really prefer for all caching directives to be under Cache* so that the 
> alphabetical ordering of the directives that we generate in our docs group 
> them together.  Using MemCache* and DiskCache* instead of CacheMem* and 
> CacheDisk* sort of blow that away.

+1  directives should be grouped into module namespace prefixes
    whenever possible

Not only will things sort together in web pages, but this is more
intuitive for many non-English speakers since many languages put
the adjectives after the noun, i.e. the subdescription after the


View raw message