httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Erenkrantz <jus...@erenkrantz.com>
Subject Re: mod_disk_cache directives naming convention
Date Thu, 07 Oct 2004 17:14:07 GMT
--On Thursday, October 7, 2004 9:08 AM -0600 Jean-Jacques Clar 
<JJCLAR@novell.com> wrote:

> All the directives for mod_mem_cache are preceded with an "M".
> The ones for mod_cache are starting with a "c"
> Should all the disk_cache directives be preceded with a "D" for
> consistency and clarity?
> I know it is going to break every user configuration, but before
> the modules move out of experimental is probably the less painful
> time to do that change.

I *really* don't like the M prefix at all.  I'd much prefer us to just spell 
the thing out: CacheMem* and CacheDisk* instead of MCache and/or DCache.  I 
think a single letter prefix is really ambiguous.  M what?

That said, there are a number of directives currently in mod_disk_cache that 
aren't implemented (and I don't see being implemented anytime soon): such as 
CacheSize, CacheGcInterval, CacheExpiryCheck, CacheTimeMargin, CacheGcDaily, 
CacheGcUnused, CacheGcClean, CacheGcMemUsage.

If we go through the process of renaming the directives (and I'm +1 to making 
it consistent per my first paragraph), I'd like to see us toss all of the 
directives we don't implement.

BTW, are you volunteering to take the lead on this?  ;-)  -- justin

Mime
View raw message