httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: [PATCH] use zlib-1.2.1 with mod_deflate on WIN32
Date Thu, 12 Aug 2004 18:33:27 GMT
At 04:17 AM 8/12/2004, Mladen Turk wrote:
>Hi,
>
>Small patch that enables building against zlib-1.2.1
>instead of ancient 1.1.4 version.

Ancient?  LOL - it's less than a year old due to some bugs it addressed ;-)

However, I agree with moving to 1.2.1 - with a caviat;

now that zlib1.dll is well defined, and effectively complies with our release
build strategy, I'm committing a patch to use that library

(checking out 1.2.1 in srclib/zlib/ and using make -f win32/Makefile.msc
is all that's needed to employ this version.)

Also, we must obviously distribute zlib1.dll, but in our private directory
tree under apache/bin/.  The only thing I will recommend is that we tweak
Makefile.msc to emit a .pdb file for release builds, with the exact same
optimizations, for later crash analysis.  The binary zlib1.dll will otherwise
remain 100% compatible with the 'official' zlib1.dll - allowing our users to
obtain an updated zlib1.dll without obtaining the latest mod_deflate.so.

The old zlib.dll was pretty horrid.  I think the zlib.org group got it right,
this time around, with zlib1.dll.

Bill



Mime
View raw message