httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mladen Turk" <mt...@apache.org>
Subject RE: [PATCH] mod_proxy -- enable using 2.1-HEAD on 2.0-HEAD
Date Sun, 01 Aug 2004 10:57:35 GMT
 

Justin Erenkrantz wrote:

> > -        if ((rv = apr_socket_create(newsock, backend_addr->family,
> > +#if (APR_VERSION_MAJOR > 0)
> > +        if ((rv = apr_socket_create(
> > +#else
> > +        if ((rv = apr_socket_create_ex( #endif
> > +                                    newsock, backend_addr->family,
> 
> Shouldn't that be APR_MAJOR_VERSION?

Yes, typo on copy paste to cvs tree :).

>  I'm also not sure how 
> many C pre-processors handle conditionals like that.  Does 
> HP's and IBM's?  -- justin
> 

Well, the mod_ssl uses a lot of those '#if (xxx > yyy)' so I think that's
supported.

MT.

Mime
View raw message