httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brad Nicholes" <BNICHO...@novell.com>
Subject Re: huge memory leak in 2.0.x
Date Mon, 14 Jun 2004 19:45:26 GMT
   Actually I think this was addressed quite a while ago with the
introduction of the MaxMemFree directive.  This problem sounds a lot
like the bucket issue where memory allocated for the bucket brigade that
pushes the data through from the CGI app to the wire, simply held on to
the memory assuming that it would be needed later.  The MaxMemFree
directive allowed the memory pool manager to release excess memory
rather than allowing it to hang around.

Brad  

Brad Nicholes
Senior Software Engineer
Novell, Inc., the leading provider of Net business solutions
http://www.novell.com 

>>> mh@nadir.org Monday, June 14, 2004 11:55:29 AM >>>
Hi,

[I'm writing to the dev list because it seems that not enough apache
developers have noticed or taken interest into the original PR's
on this bug]

This is a real and easy to reproduce bug that has been agonizing me
for a quite a while. It's been reported since at least October '03.
1.3.x does not show this behaviour. Please see the original report at
http://issues.apache.org/bugzilla/show_bug.cgi?id=23567 

and my report at
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=29528 

I've tried looking into the problem, but unfortunatly, I have no
knowledge/background of the apache source.

I'll test any patches.

Cheers,

-m



Mime
View raw message