httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brad Nicholes" <BNICHO...@novell.com>
Subject Re: ErrorHeader directive...
Date Thu, 03 Jun 2004 15:39:07 GMT
  Since there is a proposal to backport this directive to the 2.0 branch, would it make more
sense to rename it to something else and avoid the confusion before it is backported?  It
just seems a little strange to be getting an error header back in a successful response. 
If the point is to allow a specific header to be returned for all responses, we should probably
expand the options for the Header directive rather than add a new directive.

Syntax: Header set|append|add|unset|echo  header [value [env=[!]variable]] [persist]

persist 
The response header with this name is included even on errors and persists across internal
redirects. 


Brad

Brad Nicholes
Senior Software Engineer
Novell, Inc., the leading provider of Net business solutions
http://www.novell.com 

>>> nd@perlig.de Wednesday, June 02, 2004 4:02:25 PM >>>
* "Brad Nicholes" <BNICHOLES@novell.com> wrote:

>    If an ErrorHeader is defined, shouldn't it only be included on
> non-200 http responses (ie. only on 3xx,4xx,5xx responses as the
> documentation states)?

No. The documentation states:

| This directive can replace, merge or remove HTTP response headers *also*
| during 3xx, 4xx and 5xx replies.

It's a kind of a misnomer anyway (named after r->err_headers_out).

nd
-- 
"Eine Eieruhr", erklärt ihr Hermann, "besteht aus einem Ei. Du nimmst
das Ei und kochst es. Wenn es hart ist, sind fünf Minuten um. Dann weißt
du, daß die Zeit vergangen ist."
                             -- Hannes Hüttner in "Das Blaue vom Himmel"


Mime
View raw message