httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jess Holle <je...@ptc.com>
Subject Re: mod_ldap & Win32
Date Fri, 04 Jun 2004 17:06:03 GMT
Graham Leggett wrote:

> Jess Holle wrote:
>
>> My feedback was mainly attached to bug #18756 
>> <http://issues.apache.org/bugzilla/show_bug.cgi?id=18756>.  This bug 
>> is still present in 2.0.49.  I do not know if it is a true duplicate 
>> as indicated or not.  I just know it does not work.
>>
>> I also had reported 24801 
>> <http://issues.apache.org/bugzilla/show_bug.cgi?id=24801> (crash on 
>> cache overflow).  I believe I tested it with the fix for bug #29207 
>> <http://issues.apache.org/bugzilla/show_bug.cgi?id=29207> some time 
>> back but the problem was still there.
>>
>> My test case for latter bug the is pretty simple:
>>
>>    1. Generate an LDIF containing 2500 users (all with known passwords)
>>       and import it into your LDAP
>>    2. Have a simple script walk through the 2500 users doing a simple
>>       GET against an authenticated resource as one user after another
>>       and with the LDAP cache set at 2150 users.
>
>
> The way I tested it was to set the cache size to 1, logged in with one 
> user, then logged in with a second in a different browser.
>
> On cue, I got a crash on the second login, which has been fixed and 
> committed to v2.0.50-dev.
>
> Can you test against the latest HEAD (or v2.0.50-dev) to see if it is 
> still there? There is a big difference between v2.0.49 and v2.0.50-dev.

I know I applied some patches as requested in the correspondence on bug 
#24801.  I ran the test above, rather than the simpler cache size of 1 
-- simply because realistic cache sizes for our usage will be 2000+.  It 
still failed.

There is some chance I misapplied the patch.  The note regarding my 
efforts is in the bug comments for 24801 and is dated 2004-05-24.  The 
testing was prompted by your comment on 2004-05-22 on the same bug.

--
Jess Holle


Mime
View raw message