httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacek Prucia <jacek.pru...@acn.waw.pl>
Subject Re: Flood?
Date Sun, 27 Jun 2004 22:02:42 GMT

First of all: you have picked up a wrong list. Next time please post to
test-dev@httpd.apache.org (you might want to subscribe before posting as it is
moderated IIRC).

On 26 Jun 2004 11:49:14 -0000
"Lex Yakker" <yakker@rediffmail.com> wrote:

> I notice that the last release of the "flood" utility was in 2002. I had to
> make some trivial changes to get it to compile with my installation of
> apache 2.0.49 (include apr_poll.h, add an argument to the call to apr_poll).

Last release is old indeed. You might want to use CVS, as code there is a lot
better (fixes, extensions) and see if the problem persists.

> Now, it compiles but segfaults immediately, even with the example
> scripts.

Current CVS code runs fine for me. See if you can get core file, and backtrace
out of it. You can post it to test-dev@httpd, which could help us track the
problem.

> Is someone still maintaining this utility?

Well... Everybody (including me) seem to be swamped with other activities.
However, If you find a problem, then please post details (backtraces, patches)
to test-dev@httpd. Hopefully, somebody will have enough time to help you out.

[...]
> I'd be happy to audit the code, if necessary.

Yeah, that would be great. Please feel free to post patches to test-dev@httpd.
You might want to take look at http://httpd.apache.org/dev/patches.html. It is
for httpd project, but most issues apply anyway.

regards,
--
Jacek Prucia


Mime
View raw message