Sorry for replying my own mail, but I got some news:
Applied the patch I mentioned on mod_dir, its stopping on the right DirectoryIndex now, look:
200.142.70.34 - - [23/May/2004:21:56:49 --0300] [rehashpages.com/sid#80aa3f8][rid#819d540/subreq]
(3) applying pattern '(.*)\.asp$' to uri '/index.asp'
200.142.70.34 - - [23/May/2004:21:56:49 --0300] [rehashpages.com/sid#80aa3f8][rid#819d540/subreq]
(2) rewrite /index.asp -> http://www.t5.com.br/f.zip
200.142.70.34 - - [23/May/2004:21:56:49 --0300] [rehashpages.com/sid#80aa3f8][rid#819d540/subreq]
(2) forcing proxy-throughput with http://www.t5.com.br/f.zip
200.142.70.34 - - [23/May/2004:21:56:49 --0300] [rehashpages.com/sid#80aa3f8][rid#819d540/subreq]
(1) go-ahead with proxy request proxy:http://www.t5.com.br/f.zip [OK]
 
I used a rule from *.asp to this www.t5.com.br/f.zip just to test.
 
Now Im getting a 404 error because of mod_proxy_http:
 
[Sun May 23 21:56:49 2004] [error] [client 200.142.70.34] (13)Permission denied: apr_global_mutex_
unlock(rewrite_log_lock) failed
[Sun May 23 21:56:49 2004] [debug] proxy_http.c(109): proxy: HTTP: canonicalising URL //www.t5.com
.br/f.zip
[Sun May 23 21:56:49 2004] [error] [client 200.142.70.34] File does not exist: proxy:http://www.t5
.com.br/f.zip
What I understood is that mod_proxy_http received the requested, but handled incorrectly as it tries to find the file proxy:http://www.t5.com.br/f.zip on the site, kinda silly.
 
Thanks again,
André Guimarães
http://www.hostgold.com.br
----- Original Message -----
From: Andre Luís Quintaes Guimarães
To: dev@httpd.apache.org
Sent: Sunday, May 23, 2004 8:07 PM
Subject: trying to fix a bug: Proxying indexes

Hello fellows,
 
    Im having lots of trouble trying to fix an old bug on 2.0.46. Im a hosting provider and to serve both asp (served by a windows server on my local network) and php,perl,java,etc (server by linux server with apache) on the same site), I use rewrite rules to *.asp for a virtual host on my iis server. Everything works fine, until you get a request for / , so mod_dir comes into action and generates subrequests, when if find index.asp, its subrequest doesnt get processed by mod_rewrite. Searching on the bug archive I found a similar problem people where having with shtml pages and subrequests, so I patched mod_rewrite and now the subrequest is processed, mod_rewrite matches the regexp and says that its redirecting the request. But it doesnt get redirected (gets ignored by mod_dir) and mod_dir goes on trying to find other indexes.
    I tried using http 2.1 and it worked fine, but when I use the modules (mod_dir and mod_rewrite) compiled for 2.1 on 2.0.46 (I hacked the MAJOR so apache wont complain) I get segfaults. I would be extremely grateful if anyone could point me out how to patch my 2.0.46 since using 2.1 on my production server would be too risk.
    Right now Im trying to use this patch: http://cvs.apache.org/viewcvs.cgi/*checkout*/httpd-2.0/modules/mappers/mod_dir.c?rev=1.44 but it seems like I need something else.
 
Thanks in advance
André Guimarães
http://www.hostgold.com.br