httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dermot Tynan <dty...@kalopa.com>
Subject NULL Pointer in auth module (Apache 2.0.48)
Date Sat, 22 May 2004 15:53:12 GMT
I'm at Witts End (twisty passages everwhere!).  I have
written an authentication module as a DSO for Apache 2.0.48
I run FreeBSD here and it works just fine.  I move the
source over to a SuSE 9.0 box where Apache 2.0.48 has
been installed from a binary RPM, and it compiles and
drops into /usr/lib/apache2-prefork.  The problems arise
when the module is used for authentication.  The new
commands parse just fine, but when the
authenticate_basic_user hook is called, the request_rec
pointer is empty.  The actual pointer isn't NULL, but
all the fields including the URI and per_dir_config
pointer are null.  Even if I trap the fact that
r->per_dir_config is NULL and exit with a DECLINED,
then the server returns an Error-500.  I've tried using
APXS and I've tried hand-compiling the module but
nothing works.  Google doesn't have any help.  The module
is quite similar to all other auth modules.  In fact, I
if0 a lot of the code and I still get a bogus request_rec.
I've been pounding my head against the wall for days now
and I can't figure out what's going on.  If I remove my
auth module from the config file, there are no problems.

Does anyone out there have any ideas?  Has someone come
across this before?  I suspect that I'm compiling the
module incorrectly or something, seeing as it's so simple
but I can't figure out how.  APXS does give some grief in
that it seems to want to refer to HTTP v1 on SuSE but
even hand-compiling doesn't do the right thing.
					- Der
-- 
Dermot Tynan
Kalopa Media Limited


Mime
View raw message