httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kotla, Satya \(Corporate, consultant\)" <satya.ko...@corporate.ge.com>
Subject RE: Compiling Apache 2.0.49 with worker MPM
Date Fri, 30 Apr 2004 18:36:30 GMT

I am not running FreeBSD. Our system is on Red Hat Advanced Server 2.1. Somehow "--with-mpm=worker"
option does not seem to work and during compilation for Apache 2.0.49, it is including "prefork"
MPM only. What can we do for this?

-----Original Message-----
From: ranier [mailto:ranier@cultura.com.br]
Sent: Tuesday, April 27, 2004 4:04 PM
To: dev@httpd.apache.org
Subject: Re: Compiling Apache 2.0.49 with worker MPM


Kotla, Satya (Corporate, consultant) wrote:

>But somehow after the compilation, I am seeing that it has included the "prefork" MPM
instead of "worker" I 
>
Weel, I suppose that your system is FreeBSD?
Because problems with libs (threads), doens't possible compilation 
multithread in FreeBSD with http (apr like).
Please, see post http://groups.yahoo.com/group/new-httpd/message/47705 
and your subsequentes posts.

>have ecen tried using "--with-mpm=perchild" option, but even then after compilation I
am seeing only "prefork.c" in the list of modules included after compilation. Is there something
wrong with "configure" script for Apache 2.0.49? Has anybody else faced this problem?
>
FreeBSD 5.X, apparently solved the problem...

Mime
View raw message