httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amit Athavale <amit_athav...@persistent.co.in>
Subject Re: Compiling Apache 2.0.49 with worker MPM
Date Fri, 30 Apr 2004 14:11:59 GMT
If you had earlier compiled with default MPM i.e. prefork then
do "make clean" after configure and before running "make"

If not :
1> which OS you are using ?
2> Go through config.log and see for any errors.

~Amit

Kotla, Satya (Corporate, consultant) wrote:

>Hi,
>
>We are trying to compile Apache 2.0.49 source with "worker" MPM and used the following
commands:
>./configure --prefix=/usr/local/apache --enable-so --with-mpm=worker
>make
>make install
>
>But somehow after the compilation, I am seeing that it has included the "prefork" MPM
instead of "worker" MPM as I wanted. When I give "./httpd -l" command, following is the output:
>Compiled in modules:
>  core.c
>  mod_access.c
>  mod_auth.c
>  mod_include.c
>  mod_log_config.c
>  mod_env.c
>  mod_setenvif.c
>  prefork.c
>  http_core.c
>  mod_mime.c
>  mod_status.c
>  mod_autoindex.c
>  mod_asis.c
>  mod_cgi.c
>  mod_negotiation.c
>  mod_dir.c
>  mod_imap.c
>  mod_actions.c
>  mod_userdir.c
>  mod_alias.c
>  mod_so.c
>
>I have ecen tried using "--with-mpm=perchild" option, but even then after compilation
I am seeing only "prefork.c" in the list of modules included after compilation. Is there something
wrong with "configure" script for Apache 2.0.49? Has anybody else faced this problem?
>Any help will be greatly appreciated.
>
>Thanks
>Satya Kotla
>
>
>
>  
>



Mime
View raw message