httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Van Biesen <peter.vanbie...@vlafo.be>
Subject Re: Has mod_dir changed between 2.0.46 and 2.0.49 ?
Date Wed, 21 Apr 2004 11:24:40 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I use mod_jk 1.2.5. the entries are :

JkMount /*.jsp ajp13

and from the workers file :

worker.ajp13.port=8009
worker.ajp13.host=localhost
worker.ajp13.type=ajp13

Btw, the ajp connection works fine when the jsp exists, but apparently
mod_dir sends index.jsp to tomcat even though it does not exists ...

When you add index.jsp to your configuration and add the above worker
en JkMount entry, does it work for you ?

Kindest regards,

Peter.

jean-frederic clere wrote:

| Peter Van Biesen wrote:
|
|> Hi,
|>
|> I've recently migrated from 2.0.46 to 2.0.49 and I have a strange
|> problem. In 2.0.46, my DirectoryIndex was set to include
|> index.jsp, so if a directory contains a index.jsp, tomcat was
|> contacted to serve this. However, when I do this in 2.0.49 tomcat
|> is contacted even if there's no index.jsp, so where I got a
|> response from autoindex I now get a 404 from tomcat.
|>
|> I removed the index.jsp from my DirectoryIndex and added it
|> everywhere I know there's one, so now it all seems to work, but
|> I'm wondering : is this a bug in the 2.0.46 or in the 2.0.49 ? Or
|> should I change something in my configuration ?
|
|
| What do you use to connect to Tomcat?
|
|>
|> Thanks in advance !
|>
|> Peter.
|>
|
|
|

- --
Peter Van Biesen
Adj. Sysadmin V.F.S.I.P.H.

tel: +32 (0) 2 225 85 70
fax: +32 (0) 2 225 85 88
e-mail: peter.vanbiesen@vlafo.be
PGP: http://www.vlafo.be/pgpkeys/peter.vanbiesen@vlafo.be.pub.asc
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFAhln4HtEPd3S05zgRAnAaAKCa+q1SETbdzREnvTzBAWNxqteQzACgiz9Q
u3mMiMgzA+xfYLXXtw2HMcY=
=Vy0L
-----END PGP SIGNATURE-----


Mime
View raw message