httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marc G. Fournier" <>
Subject Re: FreeBSD 4.x and Apache2: worker MPM issue
Date Sun, 07 Mar 2004 20:50:07 GMT
On Sun, 7 Mar 2004, Paul Querna wrote:

> On Sat, 2004-03-06 at 18:50, Marc G. Fournier wrote:
> > Actually, I think it might have been fixed ... On my Jan 6th FreeBSD
> > server, I am getting weird responses with threading enabled, but two of my
> > others ones (Jan 23rd nd Feb 4th) both seem to be working consistently ...
> On my 4.9-STABLE machine built today:
> FreeBSD 4.9-STABLE FreeBSD 4.9-STABLE #8: Sun
> Mar  7 10:49:58 PST 2004
>  i386
> The worker MPM built from CVS HEAD as of Today does not work.
> It still exhibits the broken behavior as Justin has described it.
> Are you sure your machines are 4.9-STABLE and you are running the worker
> MPM?  Do you have something special in your configuration?

4.9-STABLE FreeBSD 4.9-STABLE #5: Fri Jan 23


4.9-STABLE FreeBSD 4.9-STABLE #7: Wed Feb  4

# /usr/local/sbin/httpd -V
Server version: Apache/2.0.48
Server built:   Mar  4 2004 16:47:08
Server's Module Magic Number: 20020903:4
Architecture:   32-bit
Server compiled with....
 -D APACHE_MPM_DIR="server/mpm/worker"
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D HTTPD_ROOT="/usr/local"
 -D SUEXEC_BIN="/usr/local/bin/suexec"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_ERRORLOG="/var/log/httpd-error.log"
 -D AP_TYPES_CONFIG_FILE="etc/apache2/mime.types"
 -D SERVER_CONFIG_FILE="etc/apache2/httpd.conf"

Now, from the way that Justin explains it, its possible that the hits are
continous enough not to exhibit the problem?

Marc G. Fournier           Hub.Org Networking Services (
Email:           Yahoo!: yscrappy              ICQ: 7615664

View raw message