httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mathihalli, Madhusudan" <mad...@hp.com>
Subject RE: Broken SSL connections on load ?
Date Tue, 09 Mar 2004 22:00:50 GMT
>-----Original Message-----
>From: Joe Orton [mailto:jorton@redhat.com]
[SNIP]
>On Mon, Mar 08, 2004 at 11:59:44AM -0800, Mathihalli, Madhusudan wrote:
>> 	I've been using the sslswamp tool (which btw is great) to stress
>> 	apache - and once in a while, I keep getting a 'abortive close'
>> 	with the following message in the error_log. Any ideas why this
>> 	is happening ? 
>...
>> [Mon Mar 08 11:56:16 2004] [info] (70014)End of file found: 
>SSL handshake interrupted by system [Hint: Stop button pressed 
>in browser?!]
>> [Mon Mar 08 11:56:16 2004] [info] Connection to child 85 
>closed with abortive shutdown(server yuki.cup.hp.com:443, 
>client 15.0.107.44)
>
>You'd expect to see errors like that e.g. if you SIGTERM swamp 
>before it
>finished.  If that message was changed to log the client port too it
>would be easy enough to check with tcpdump whether or not the client
>really sent any data...


This is what I got from tusc - but I can't believe ssldump sent nothing (because the connection
was established)

accept(5, 0x6000000000529618, 0x6000000000529634) = 39
getsockname(39, 0x60000000005295c0, 0x60000000005295dc) = 0
setsockopt(39, 0x6, TCP_NODELAY, 0x9fffffffeeb70f84, 4) = 0
fcntl(39, F_GETFL, 0) ... = 2
fcntl(39, F_SETFL, 65538) = 0
read(39, 0x60000000005d4768, 8000) = 0
close(39) ............... = 0

-Madhu

Mime
View raw message