httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brad Nicholes" <BNICHO...@novell.com>
Subject Re: [PATCH] bug #18756 ldap cache and shared memory - cache init
Date Fri, 12 Dec 2003 19:59:35 GMT
   I don't have a problem with this patch, but since NetWare doesn't use
shared memory I am not able to trace down exactly what the issue is. 
Can you describe the circumstance where the util_ald_create_cache()
function is called and st->cache_rmm is invalid?  By simply looking
through the code, it appeared that st->cache_rmm is always set before
any call to util_ald_create_cache().

Brad

Brad Nicholes
Senior Software Engineer
Novell, Inc., the leading provider of Net business solutions
http://www.novell.com 

>>> apache@moresecurity.org Thursday, December 11, 2003 1:51:49 AM >>>
Hi,

st->cache_rmm is now invalid because due to non SHM plateform,
bnicholes 
changed the alloc function util_ald_alloc to receive now 
util_ald_cache_t and no more apr_rmm_t.
As we are just before the cache alloc, it's impossible to give 
util_ald_alloc a cache object, that's why there, i did a basic alloc 
functions.


Jeff Trawick wrote:

> Matthieu Estrade wrote:
>
>> Here is a little patch, fixing the ldap cache using shared memory.
>> After the fix for plateform using SHM or not, it was a problem with

>> cache init, unable to get it's rmm address to alloc memory.
>
>
> why is st->cache_rmm not filled out (or invalid)?
>
>



Mime
View raw message