httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Kew <>
Subject Re: r->filename.
Date Sun, 26 Oct 2003 01:43:19 GMT
> how about something like
> ap_request_filename(r) that returns ptr to filename or NULL

Hmmm ... ap_request_filename(r, dflt) ?

Now, this discussion bothers me.  Surely, for a module to use
r->filename when it might be unset is broken, and should be fixed
properly rather than left (potentially) to fail silently?

> probably Apache core shouldn't change the (vague) semantics of r->filename but
> it can provide the access functions mentioned above

Would it be less error-prone to call it something different?
Like ap_path_translated(r), for instance?

> modules for 2.0 that look at r->filename could call ap_request_filename() or
> ap_request_filename_str() depending on the requirement (dumb logging code would
> just call _str() version)

Even dumb logging code might be better with a printable placeholder,

Nick Kew

View raw message