httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@attglobal.net>
Subject Re: any Perl history experts out there?
Date Fri, 19 Sep 2003 19:32:06 GMT
Glenn wrote:

> On Fri, Sep 19, 2003 at 02:05:39PM -0400, Jeff Trawick wrote:
> 
>>Glenn wrote:
>>
>>>On Fri, Sep 19, 2003 at 11:49:03AM -0400, Jeff Trawick wrote:
>>>
>>>
>>>>a.k.a. "What should the apxs 2.0 require statement say?"

> I'm not sure when 
>   my $cntopen = () = ($before =~ m|^\s*<[^/].*$|mg);
> starts working.  I'd guess 5.004 since I've been using this trick
> for quite a while.  Even so, I think following works with any Perl 5:
>   my $cntopen = @{[($before =~ m|^\s*<[^/].*$|mg)]};

I found an old perl 5.004 on an old OS/390 box and it didn't complain. 
I'll update the require to 5.004.

> For more info:
> 
> man perl5004delta
> man perl5005delta
> man perl56delta
> man perl561delta

nice tip!!  I didn't know about that...

Thanks,

Jeff



Mime
View raw message