httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Blair Zajac <bl...@orcaware.com>
Subject RE: server/exports.c includes now missing apu_compat.h
Date Sat, 06 Sep 2003 06:08:28 GMT
> Subject: RE: server/exports.c includes now missing apu_compat.h
> Date: Fri, 5 Sep 2003 19:38:17 +0200
> From: "Sander Striker" <striker@apache.org>
> To: <dev@httpd.apache.org>
> 
> > From: Blair Zajac [mailto:blair@orcaware.com]
> > Sent: Friday, September 05, 2003 7:32 PM
> 
> > Hello,
> >
> > Just tried building apr/apr-util and httpd-2.1 from CVS head and got
> > the following compile error:
> 
> [...]
> > If I manually delete 'include "apu_compat.h"' from exports.c it
> > compiles just fine.
> 
> Did you run ./buildconf ?

Yes.  I have a shell script that I use to build apr/apr-util and
httpd-2.1.  The script doesn't change and it just broke since the
ap*_comput.h files were removed.

apache_dir_to_use=httpd-2.1

if test -d $apache_dir_to_use; then
        set -e

        if true; then
                # rm -fr apr apr-util
                # cvs -d :pserver:anoncvs@cvs.apache.org:/home/cvspublic co apr
                # cvs -d :pserver:anoncvs@cvs.apache.org:/home/cvspublic co apr-util

                tag="-r APACHE_2_0_BRANCH"
                if test -d $apache_dir_to_use/CVS; then
                        cd $apache_dir_to_use
                        #cvs update -dP $tag
                        cd ..
                else
                        rm -fr $apache_dir_to_use
                        cvs -d :pserver:anoncvs@cvs.apache.org:/home/cvspublic co $tag $apache_dir_to_use
                fi
                if test -d h; then
                        mv h h.$$
                        rm -fr h.$$ &
                fi
                mkdir h
                cd h
                cptree -x CVS ../$apache_dir_to_use . >/dev/null
                cd srclib/
                mkdir apr
                #lndir ../../../apr apr
                cptree -x CVS ../../apr apr >/dev/null
                mkdir apr-util
                #lndir ../../../apr-util apr-util
                cptree -x CVS ../../apr-util apr-util >/dev/null

                cd ..
                ./buildconf 2>&1 | tee xxa
        fi

> > Should httpd 2.1 compile and link against APR 1.0 branch or CVS HEAD
> > now, as include/apr_compat.h, and include/apu_compat.h were removed
> > from HEAD.
> 
> HEAD.  There is no 1.0 branch, only a 0.9 branch.

Right, 0.9.  The apr_compat.h was removed in HEAD.

Best,
Blair

-- 
Blair Zajac <blair@orcaware.com>
Plots of your system's performance - http://www.orcaware.com/orca/

Mime
View raw message