httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Blair Zajac <bl...@orcaware.com>
Subject server/exports.c includes now missing apu_compat.h
Date Fri, 05 Sep 2003 17:31:58 GMT
Hello,

Just tried building apr/apr-util and httpd-2.1 from CVS head and got
the following compile error:

gawk -f /export/home1/blair/Code/Apache/2.0/h/build/make_exports.awk
`cat export_files` > /export/home1/blair/Code/Apache/2.0/h/server/exports.c
/export/home1/blair/Code/Apache/2.0/h/srclib/apr/libtool --silent
--mode=compile gcc  -pthread  -g -O2 -std=c89 -Wall -I/usr/kerberos/include
-Wl,-rpath,/opt/i386-linux/db-4.1/lib  -DLINUX=2 -D_REENTRANT
-D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_SVID_SOURCE -D_GNU_SOURCE
-DAP_HAVE_DESIGNATED_INITIALIZER
-I/export/home1/blair/Code/Apache/2.0/h/srclib/apr/include
-I/export/home1/blair/Code/Apache/2.0/h/srclib/apr-util/include
-I/opt/i386-linux/db-4.1/include -I.
-I/export/home1/blair/Code/Apache/2.0/h/os/unix
-I/export/home1/blair/Code/Apache/2.0/h/server/mpm/prefork
-I/export/home1/blair/Code/Apache/2.0/h/modules/http
-I/export/home1/blair/Code/Apache/2.0/h/modules/filters
-I/export/home1/blair/Code/Apache/2.0/h/modules/proxy
-I/export/home1/blair/Code/Apache/2.0/h/include
-I/export/home1/blair/Code/Apache/2.0/h/modules/generators
-I/export/home1/blair/Code/Apache/2.0/h/modules/dav/main
-prefer-non-pic -static -c
/export/home1/blair/Code/Apache/2.0/h/server/exports.c &&
touch /export/home1/blair/Code/Apache/2.0/h/server/exports.lo
In file included from /export/home1/blair/Code/Apache/2.0/h/server/exports.c:12:
/export/home1/blair/Code/Apache/2.0/h/include/ap_compat.h:5:24:
apu_compat.h: No such file or directory
make[2]: *** [/export/home1/blair/Code/Apache/2.0/h/server/exports.lo] Error 1
make[2]: Leaving directory `/export/home1/blair/Code/Apache/2.0/h/server'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/export/home1/blair/Code/Apache/2.0/h/server'
make: *** [all-recursive] Error 1

If I manually delete 'include "apu_compat.h"' from exports.c it
compiles just fine.

Should httpd 2.1 compile and link against APR 1.0 branch or CVS HEAD
now, as include/apr_compat.h, and include/apu_compat.h were removed
from HEAD.

Best,
Blair

-- 
Blair Zajac <blair@orcaware.com>
Plots of your system's performance - http://www.orcaware.com/orca/

Mime
View raw message