httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ron Park <ronald.p...@cnet.com>
Subject RE: mod_include: YABU (yet another bug uncovered)
Date Thu, 07 Aug 2003 20:53:57 GMT
Oops, I may have sent this off too hurriedly; looks like both
example core... the first one wasn't coring when I used Cntl-B
instead of Cntl-P and I think my browser was caching it.

The 'good' news is, there's two examples that show a core dumping
problem. :)

Ron

> -----Original Message-----
> From: Ron Park [mailto:ronald.park@cnet.com] 
> Sent: Thursday, August 07, 2003 4:09 PM
> To: 'dev@httpd.apache.org'
> Subject: mod_include: YABU (yet another bug uncovered)
> 
> 
> Hi Again,
> 
> Well, we've come across another mod_include/cross brigade bug 
> for which we
> currently don't yet have a patch (should have one soon but 
> thought I'd give
> others a crack at it). :D
> 
> Here are two simple snippets, one which works, one which causes a core
> dump even with the latest patch of mod_include:
> 
> <!--#if expr="$FALSE" -->True<!^P--#set var="v" value="t" 
> -->Set<!--#else -->False<!--#set var="v" value="t" 
> -->Set<!--#endif -->Done
> 
> <!--#if expr="$FALSE" -->T<!^P--#set var="v" value="t" 
> -->Set<!--#else -->False<!--#set var="v" value="t" 
> -->Set<!--#endif -->Done
> 
> (The Cntl-P is to cause mod_bucketeer to fire off: need the following
> setting in your conf file to get this to work:
> 
> AddOutputFilter BUCKETEER;INCLUDES .html
> 
> Put each snippet in a file in your docroot, say, true.html 
> and t.html and give
> them a try.
> 
> I'm pretty sure it's related to the code around line 491 of 
> mod_include.c
> (at least that's the part that works differently for each 
> one) but I haven't
> figured out how it's wrong.
> 
> Thanks,
> Ron
> 

Mime
View raw message