httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bastiaan van der Put <...@web4friends.com>
Subject Re: [users@httpd] Re: Perl Processes "Zombie-Out"... (fwd)
Date Sun, 20 Jul 2003 19:42:29 GMT
correct, 1.3.28 creates zombie's,

running cgi with suexec.

Bas
At 15:37 7/20/2003 -0400, you wrote:
>For those who don't monitor the users list or bug database: There was a
>regression in 1.3.28 that causes zombie cgi processes.
>
>I haven't looked at any of the details.
>
>Joshua.
>
>
>---------- Forwarded message ----------
>Date: 20 Jul 2003 14:58:08 -0400
>From: J. Nick Koston <nick@cpanel.net>
>Reply-To: users@httpd.apache.org
>To: users@httpd.apache.org
>Subject: Re: [users@httpd] Re: Perl Processes "Zombie-Out"...
>
>I've posted a better patch to
>
>http://nagoya.apache.org/bugzilla/show_bug.cgi?id=21737
>
>I've also explained why this happens on the bug.
>
>/Nick
>
>On Sun, 2003-07-20 at 13:51, J. Nick Koston wrote:
> > Here is what I know so far
> >
> > 1. Its a bug in 1.3.28, 1.2.37 is NOT AFFECTED.
> > 2. This appears to only happen when using suexec (I have not tested that
> > theory yet though)
> > 3. The bug is in src/main/alloc.c.
> > 4. The attached patch which has been backported from 1.3.27 fixes the
> > problem.
> > 5. This should be considered serious enough to release 1.3.29 as I've
> > watched about 10 systems spiral down to their doom as a result of this.
> > 6.  A Quick How to replicate the problem:
> >
> > a) Put a this script in your cgi-bin
> > --cut here--
> > #!/usr/bin/php
> > <?php phpinfo(); ?>
> > --cut here--
> >
> > b) Go to it your web browser.  Click reload over and over again (this
> > will eventually cause a sigpipe).
> >
> > c) watch the zombies build up
> >
> > Thanks!
> > /Nick
> >
> > On Sun, 2003-07-20 at 13:13, Joshua Slive wrote:
> > > To start, you need to identify exactly what version of apache you are
> > > running.
> > >
> > > I've seen a couple reports in the apache bug database of zombie cgi
> > > scripts after upgrading from 1.3.27 to 1.3.28.  Is that your case, or did
> > > the problem exist with earlier versions?
> > >
> > > Joshua.


Mime
View raw message