httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark W. Webb" <m...@dolphtech.com>
Subject apache not passing cert chain to servlet or CGI
Date Mon, 07 Jul 2003 17:36:58 GMT
I have been working on a site that enforces mutually authenticated SSL 
using apache 2.0.46. I have compiled it from source using the following 
commands passed to the ./configure script:

./configure --enable-so --enable-ssl --with-ssl=/usr/local/ssl

/usr/local/ssl contains openssl version 0.9.7b which I compiled from 
source using the default build configuration. I have tried both servlets 
and cgi and all I can get is the user certificate, not the certificate 
chain.  I have tried looking at the mod_ssl code, and cannot figure out 
why the +ExportCertData directive will only tell apache to forward on 
the user certificate, not the chain.

Can anyone provide me with some direction as to how I can get apache to 
send the certificate chain to either a cgi or servlet.

Thank you 



Mime
View raw message