httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ron Park <ronald.p...@cnet.com>
Subject RE: Two mod_include problems
Date Mon, 21 Jul 2003 21:14:32 GMT
Does the test case have the following turned on?

AddOutputFilter BUCKETEER;INCLUDES .shtml

Ron

> -----Original Message-----
> From: Cliff Woolley [mailto:jwoolley@virginia.edu] 
> Sent: Monday, July 21, 2003 4:55 PM
> To: dev@httpd.apache.org
> Cc: Ron Park
> Subject: RE: Two mod_include problems
> 
> 
> On Mon, 21 Jul 2003, Cliff Woolley wrote:
> 
> > > Ok, here's a small test file that shows that that
> > > mod_include patch is not working properly (using
> > > mod_bucketeer notation, all one line):
> > >
> > > Before If <!-- comment --><!--#if expr="$FALSE" 
> -->Anything^FNothing<!--#else -->SomethingElse<!--#endif 
> --><!-- right after if -->After if
> 
> I just added this exact test to httpd-test.  But it passes 
> for me.  Are
> you sure you have a cleanly-patched mod_include?  Maybe 
> there's a remnant
> of a prior patch left in there?
> 
> The test file is at:
> 
http://cvs.apache.org/viewcvs/*checkout*/httpd-test/perl-framework/t/htdocs/modules/include/bucketeer/y7.shtml

I checked it twice but you can look over it too.  The test result I get
is:

# testing : GET /modules/include/bucketeer/y7.shtml
# expected: Before If <!-- comment -->SomethingElse<!-- right after if
-->After if
# received: Before If <!-- comment -->SomethingElse<!-- right after if
-->After if
ok 55
ok
All tests successful.


--Cliff

Mime
View raw message