httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill Stoddard <b...@wstoddard.com>
Subject Re: FW: httpd.exp for Apache 2.0.43
Date Mon, 02 Jun 2003 14:01:00 GMT
Rahul Kohli wrote:

>Thanks Jeff.
>
>I am facing the same type of problem mentioned by you. Originally I was running my application
on Apache 1.3.26 & i was using httpd.exp. It was working fine. apachectl start started
the server properly & our library was loaded.
>
>Now we are switching to apache 2.0.43 and facing error while starting apachectl. The error
is as below:
>Syntax error on line 147 of /usr/apache/conf/httpd.conf:
>Cannot load /home/agent5x/Installables/lib/my_lib.so into server:
>
>I am using the httpd.exp as I did in 1.3.26. With this appraoch my library is not even
getting loaded. As per suggested by you in your reply it seems that the problem is with httpd.exp
approach. You mentioned the runtime linking approach. Which runtime libraries i need to link
my application with. 
>
>It will be of great help to us.
>
>Kindly advise,
>  
>
>>Rahul Kohli
>>    
>>
apxs uses apr-config. Check out the LDFLAGS in apr-config, in particular 
the -brtl option.  Your best bet is to use apxs to compile your modules. 
That way, you will be sure to pick up all the right compile and link 
options, macro definitions, etc.

http://httpd.apache.org./docs-2.0/programs/apxs.html

Bill



Mime
View raw message