httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Akins <bak...@web.turner.com>
Subject Re: httpd-2.0.46 needs gcc_s? (on solaris 8)
Date Thu, 05 Jun 2003 19:42:59 GMT
Build it with CFLAGS=-static-libgcc



On Thu, 2003-06-05 at 05:18, harald deppeler wrote:
> We're upgrading from 2.0.44 to 2.0.46 and have noticed that the httpd
> binary now seems to need libgcc_s.
> 
> # ldd /some/path/httpd
>         libaprutil-0.so.0 =>     /some/path/lib/libaprutil-0.so.0
>         libexpat.so.0 =>         /some/path/lib/libexpat.so.0
>         libapr-0.so.0 =>         /some/path/lib/libapr-0.so.0
>         librt.so.1 =>    /usr/lib/librt.so.1
>         libm.so.1 =>     /usr/lib/libm.so.1
>         libsocket.so.1 =>        /usr/lib/libsocket.so.1
>         libnsl.so.1 =>   /usr/lib/libnsl.so.1
>         libresolv.so.2 =>        /usr/lib/libresolv.so.2
>         libdl.so.1 =>    /usr/lib/libdl.so.1
>         libpthread.so.1 =>       /usr/lib/libpthread.so.1
>         libc.so.1 =>     /usr/lib/libc.so.1
>         libgcc_s.so.1 =>         (file not found)
>         libgcc_s.so.1 =>         (file not found)
>         libgcc_s.so.1 =>         (file not found)
>         libaio.so.1 =>   /usr/lib/libaio.so.1
>         libmp.so.2 =>    /usr/lib/libmp.so.2
>         libthread.so.1 =>        /usr/lib/libthread.so.1
>         /usr/platform/SUNW,Ultra-250/lib/libc_psr.so.1
> #
> 
> 
> Our build systems have gcc (3.2.1) and other development tools
> installed. Our roll-out systems are stripped down and contain no
> such libraries, compilers or tools.
> 
> What would be the recommended way to roll out our 2.0.46 package? Include
> libgcc_s with it? Roll out an "Apache>2.0.44" supporting package including
> the necessary lib(s)? Configure Apache in such a way that it doesn't
> use libgcc_s? How would we do the latter (preferred)?
> 
> Cheers - Harry
-- 
Brian Akins <bakins@web.turner.com>
CNN Internet Technologies


Mime
View raw message