httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Graham Leggett <minf...@sharp.fm>
Subject Re: httpd v2.0 compile fails with mod_so on Linux
Date Sun, 30 Mar 2003 10:26:20 GMT
Joe Orton wrote:

>>./configure  --enable-mods-shared=all
>>
>>checking whether to enable mod_userdir... shared (all)
>>checking whether to enable mod_alias... shared (all)
>>checking whether to enable mod_rewrite... shared (all)
>>configure: error: shared objects have been requested but cannot be built 
>>since mod_so cannot be built
>>
>>Again, I have attached config.log - any clues?
> 
> ...
> 
>>configure:15185: /include/apr.h: No such file or directory
>>configure:15168: error: shared objects have been requested but cannot be built since
mod_so cannot be built
> 
> 
> This is the same problem as in the other config.log you posted -
> APR_CHECK_APR_DEFINE can't find apr.h, so all the checks for APR_HAS_foo
> are failing.
> 
> Maybe try adding a "echo CPPFLAGS are $CPPFLAGS" line after:
> 
> CPPFLAGS="$CPPFLAGS $INCLUDES"
> 
> n APR_CHECK_APR_DEFINE to see why not.

I tried this, but the configure script bombs out before this line so I 
never get to see these values. Surely CPPFLAGS should be set before the 
module checks? It looks like it is being set after the module checks, 
which might explain why it is failing.

Regards,
Graham
-- 
-----------------------------------------
minfrin@sharp.fm		"There's a moon
					over Bourbon Street
						tonight..."


Mime
View raw message