httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Ames <grega...@apache.org>
Subject [PATCH] build problem with stable and older libtool
Date Tue, 25 Mar 2003 00:16:44 GMT
I'm trying to get WROWE_2_0_45_RC1 going on daedalus and got:

/home/gregames/httpd-2.0.45-wr1/shlibtool: 
/home/gregames/httpd-2.0.45-wr1/shlibtool: No such file or directory
*** Error code 127

...when make tried to build mod_access (the first module we build as a DSO). 
This is a symptom of using libtool 1.3 without having ltconfig and ltmain.sh 
accessable to httpd's configure.  Looks like we need 1.29 and 1.31 in the tag.
That's what this patch does, in addition to tweaking the comment a little to 
make it more obvious why this code is important.

This patch solves the problem.  Can I get some +1's on committing it to the 
stable branch?

Thanks,
Greg

Index: buildconf
===================================================================
RCS file: /home/cvspublic/httpd-2.0/buildconf,v
retrieving revision 1.27.2.3
diff -u -d -b -r1.27.2.3 buildconf
--- buildconf   11 Mar 2003 07:07:52 -0000      1.27.2.3
+++ buildconf   25 Mar 2003 00:04:20 -0000
@@ -162,6 +162,14 @@
     $apr_src_dir/build/PrintPath $apr_src_dir/build/apr_common.m4 \
     $apr_src_dir/build/find_apr.m4 $apu_src_dir/build/find_apu.m4 build

+# Copy libtool-1.3.x files if they exist
+if [ -f $apr_src_dir/build/ltconfig ]; then
+    cp $apr_src_dir/build/ltconfig build
+fi
+if [ -f $apr_src_dir/build/ltmain.sh ]; then
+    cp $apr_src_dir/build/ltmain.sh build
+fi
+
  echo rebuilding $pcre_configure
  (cd srclib/pcre && ${AUTOCONF:-autoconf})



Mime
View raw message