httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Trevor Hurst <t...@sgi.com>
Subject Re: Apache 2.0.44 w/ auth_ldap build errors
Date Fri, 28 Feb 2003 22:04:07 GMT

Anyone in users have this problem, or should I say
how mny out there have successfully compiled apache2.0.44
with ldap and auth-ldap support?

Did anyone have the same problem I'm experiencing?

- Trev


Trevor Hurst wrote:
> 
> Cliff Woolley wrote:
> >
> > On Thu, 27 Feb 2003, Jeff Trawick wrote:
> >
> > > it would be useful if ./configure --help for Apache would also display
> > > apr and apr-util --help screen if the Apache configure is going to
> > > configure apr and apr-util as well
> >
> > ++1!
> 
> Please, someone try to help me out here again... argh! ;-/
> 
> I've installed OpenLDAP to use the headers and libs but
> still to no avail...same error when I pass it the info
> for the configure:
> 
> ./configure --with-ldap --enable-ldap --enable-auth-ldap
> --with-ldap-include=/usr/freeware/include/ \
> --with-ldap-lib=/usr/freeware/lib32 --with-ldap=libldap.so.3
> 
> checking for ldap support...
>   setting APRUTIL_INCLUDES to "-I/usr/freeware/include/"
>   setting APRUTIL_LDFLAGS to "-L/usr/freeware/lib32"
> checking for ldap_init in -l... no
> configure: error: could not find an LDAP library
> configure failed for srclib/apr-util
> 
> -------oOo-------
> 
> Why doesn't it like/see my ldap library I'm pointing it to?
> Am I supposed to use some development libraries instead??
> 
> I'm at a complete loss of what in the world it's wanting!?
> 
> Any ideas guys?
> 
> Thanks,
> 
> -- Trev

Mime
View raw message