httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brad Nicholes" <BNICHO...@novell.com>
Subject Re: mod_auth_ldap vs mod_ldap (was: Re: authz / authn and mod_auth_ldap)
Date Wed, 22 Jan 2003 15:24:10 GMT
Thanks,  that is the information that I was looking for.  I just wanted
to raise the issue because I wasn't sure if there were any other uses
for mod_ldap besides auth_ldap.  It appears that there is and that is
reason enough to leave it as is.  Although I do agree that mod_ldap
should be renamed to libldap to reflect what it truely is.



Brad Nicholes
Senior Software Engineer
Novell, Inc., the leading provider of Net business solutions
http://www.novell.com 

>>> dirkx@webweaving.org Wednesday, January 22, 2003 2:16:13 AM >>>


On Wed, 22 Jan 2003, Graham Leggett wrote:

> mod_ldap is a connection pool and query cache, and can be reused by
> other apache modules that require ldap, such as a potential DAV-ldap
> module, or a proxy_ldap module, so no - I'd say a combination would
be a
> bad idea.
>
> In addition, combining mod_ldap into mod_auth_ldap makes it hard to
> split auth_ldap into authn and authz.

+1 to that; (though perhaps mod_ldap needs to be called libldap) - ldap
is
useful for a lot of other things as well; including integration into
systems like RSASecurID, SiteMinder and even some extensions to our
own
SSL module. So please keep it neutral.

Dw


Mime
View raw message