httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Erenkrantz <jerenkra...@apache.org>
Subject Re: Tagged and Rolled 2.0.44
Date Sat, 18 Jan 2003 09:52:02 GMT
--On Friday, January 17, 2003 4:50 PM -0800 Greg Stein 
<gstein@lyra.org> wrote:

> Isn't 1.4.3 needed for MacOS compatibility, and maybe one of those
> fool IBM operating systems?

And, that fool Sun one, too.  =)  I haven't consistently seen the 
problem that forced Subversion to require libtool 1.4.3 on Solaris, 
but I have seen it before.  (Which is claimed to be fixed by using 
/usr/xpg4/bin/sed rather than /usr/bin/sed.)  Therefore, at a 
minimum, libtool 1.4.3 should be the requirement for any ASF 
httpd-2.x releases.

Note that I don't think it is pressing that Sander should re-roll 
with 1.4.3, but it might not also be a bad idea, either.

> If we don't want all developers to be subject to that requirement,
> then we make make the distribution script (the tarball roller)
> enforce the stronger check.
> (in Subversion, the build check looks for autoconf 2.5x and libtool
> 1.4.x,  but the dist.sh script enforces libtool 1.4.3)

Yeah, I'd prefer we enforce that the RM have the latest tool sets not 
for all developers.  We shouldn't *require* autoconf-2.5x on the RM 
machine, but libtool-1.4.3+ is one that I think we need.  -- justin

Mime
View raw message