httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Jagielski <...@jaguNET.com>
Subject Re: Auth: Start the httpd-2.1 branch finally?
Date Mon, 14 Oct 2002 15:36:50 GMT
At 6:30 AM -0400 10/14/02, Rodent of Unusual Size wrote:
>Jim Jagielski wrote:
>>
>> William A. Rowe, Jr. wrote:
>> >
>> > Branch 2.1 now?  Only if we want to release the auth changes with all of
>> > the upgrade issues of deprecating several released module.  It doesn't matter
>> > that "only the names have changed", this is called deprecating a module,
>> > and it shouldn't happen within a GA release cycle on the same minor version.
>> >
>>
>> But we've done it before... IIRC the referer logging module for example.
>
>i wasn't allowed to deprecate mod_log_referer and mod_log_agent until
>mod_log_config was able to  provide equivalent functionality.
>

A-hem. The point (for those who were paying attention) was that it did
not require a minor bump. IIRC this happened like between 1.3.4 and 1.3.5
or something. It did *not* make us bump from 1.3 to 1.4 (or 1.2 to 1.3).
-- 
===========================================================================
   Jim Jagielski   [|]   jim@jaguNET.com   [|]   http://www.jaguNET.com/
      "A society that will trade a little liberty for a little order
             will lose both and deserve neither" - T.Jefferson

Mime
View raw message