httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From grega...@apache.org
Subject byterange filter/redirect bug?
Date Thu, 24 Oct 2002 20:17:01 GMT
check this out:

[gregames@daedalus gregames]$ grep "194.65.14.76 .*binaries.* 416 "
/logs/www/weblog | wc -l
   69763

I asked root to block this IP for a while, because we are getting a couple of
these every second.  I suspect there's an httpd bug here as well as a looping
client.  We shouldn't be returning 416 "Invalid Range" for something that's
redirected, but it sure looks like we are.  I wonder what the byterange filter
does when it sees a redirect response, and there are input Range: headers?

Greg

[gregames@daedalus gregames]$ grep "194.65.14.76 .*binaries.* 416 "
/logs/www/weblog | tail
www.apache.org 194.65.14.76 - - [24/Oct/2002:13:05:32 -0700] "GET
/dist/httpd/binaries/win32/apache_1.3.27-win32-x86-no_src.exe HTTP/1.1" 416 387
"http://www.apache.org/dist/httpd/binaries/win32/" "Mozilla/4.0 (compatible;
MSIE 5.00; Windows 98)"
www.apache.org 194.65.14.76 - - [24/Oct/2002:13:05:32 -0700] "GET
/dist/httpd/binaries/win32/apache_1.3.27-win32-x86-no_src.exe HTTP/1.1" 416 387
"http://www.apache.org/dist/httpd/binaries/win32/" "Mozilla/4.0 (compatible;
MSIE 5.00; Windows 98)"
www.apache.org 194.65.14.76 - - [24/Oct/2002:13:05:33 -0700] "GET
/dist/httpd/binaries/win32/apache_2.0.43-win32-x86-no_ssl.exe HTTP/1.1" 416 387
"http://www.apache.org/dist/httpd/binaries/win32/" "Mozilla/4.0 (compatible;
MSIE 5.00; Windows 98)"
www.apache.org 194.65.14.76 - - [24/Oct/2002:13:05:33 -0700] "GET
/dist/httpd/binaries/win32/apache_2.0.43-win32-x86-no_ssl.exe HTTP/1.1" 416 387
"http://www.apache.org/dist/httpd/binaries/win32/" "Mozilla/4.0 (compatible;
MSIE 5.00; Windows 98)"

Mime
View raw message