httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jos...@slive.ca>
Subject Re: Auth: Start the httpd-2.1 branch finally?
Date Mon, 14 Oct 2002 01:36:47 GMT
André Malo wrote:
> I've tried to find a solution. It's certainly not complete, but a first
> suggestion. I simply fetched the old module docs from the Attic, named
> them "obs_*" and modified the xslt a little bit. As proposed by
> Joshua they got the status "Obsolete" and also a large warning on top of
> the page. The modules are listed on module index
> 
> <http://cvs.apache.org/~nd/manual/mod/>

+1.  That is about what I had in mind.  The <note> at the top could be 
improved a little.  Something along the lines, "This module was replaced 
in version 2.0.44 and greater by <module>mod_...</module> (and mod_...).
For more information, see ..."

> 
> I think we need a document that explains exactly the changes and the new
> provider mechanism, so we may set links from both (pre and post) module
> docs. 

Absolutely essential before the next release.  If it is simple it can go 
in upgrading.html.  If it is complicated, it should get a separate doc 
and be linked from there.

One more note: I'd like to see the rename of mod_access reversed.  That 
just seems like a gratuitous change that hurts users and doesn't really 
help developers.

Joshua.


Mime
View raw message