httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@attglobal.net>
Subject Re: [PATCH] 1.3 NET_SIZE_T is socklen_t on OpenBSD
Date Tue, 10 Sep 2002 14:05:19 GMT
Henning Brauer wrote:
> 
> On Tue, Sep 10, 2002 at 07:12:56AM -0400, Jeff Trawick wrote:
> > Henning Brauer <hb-apache-dev@bsws.de> writes:
> > > +#define NET_SIZE_T socklen_t
> > Does this hold for every level of OpenBSD, or is a version check
> > necessary?
> 
> all versions >= 2.6 have socklen_t.
> 
> Given that We don't support anything below 3.0 any more... ;-)

Your point is well taken, but I don't think it is relevant to Apache
unless it is very 
clear that nobody uses the old releases any more.  If somebody wants to
upgrade their
Apache to pick up an Apache security fix or any other change, we want it
to work, 
regardless of the OS vendor's stance on the OS level they are using.

(My employer is an OS vendor, and when I have to round up an OS guru for
some help
with something and they happen to suggest that we remove some cruft for
supporting an 
out-of-service level of the OS, I give 'em hell :) )

> You could add a #if (OpenBSD >= 199912) if you really want.

Would you be so kind as to test such a patch and resubmit?

Thanks,

Jeff

-- 
Jeff Trawick

Mime
View raw message