httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ian Holsman <i...@apache.org>
Subject Re: Apache 1.3.x and 2.0.x Performance Issue
Date Thu, 05 Sep 2002 02:44:48 GMT
Jason Kissinger wrote:
> Ian,
> 
> Were you able to verify our test results?
> 

sorry ..
I've been out of my office for a while.
I'll have a look as soon as I get back in.

--Ian

> -Jason
> 
> 
> 
>  >Ian Holsman wrote:
>  >
>  >> Jess M. Holle wrote:
>  >>
>  >>> William A. Rowe, Jr. wrote:
>  >>>
>  >>>> At 11:54 AM 8/29/2002, Jess M. Holle wrote:
>  >>>>
>  >>>>> Jason Kissinger responded:
>  >>>>>
>  >>>>>> Windows clients hitting Solaris servers does not exhibit this
>  >>>>>> problem. Only Solaris clients hitting Windows servers. I'm
unsure
>  >>>>>> if other UN*X have this problem, Linux and Windows does not.
And
>  >>>>>> Solaris client hitting anything but Windows works fine. We
have
>  >>>>>> some HP/UX boxes that I could build wget on to test as clients,
if
>  >>>>>> that would be helpful.
>  >>>>>
>  >>>>>
>  >>>>>
>  >>>> Do the Windows boxes have the Quality of Service (QoS) Network 
> Drivers
>  >>>> installed? Are they running any firewall software? Are there any
>  >>>> unpatched
>  >>>> XP boxes with the AFD.SYS fault lying around?
>  >>>
>  >>>
>  >>>
>  >>> I don't know the answers to any of these questions.
>  >>>
>  >>> I do know that this occurs on multiple networks, i.e. ours and our
>  >>> customers, so whatever it is is not at all unusual. As such it would
>  >>> be great if either Apache was fixed or the necessary fixes to the
>  >>> Windows and/or Solaris configurations when this occurs were fully
>  >>> documented :-)
>  >>>
>  >>> Has anyone gotten *good* (e.g. something on par with 8MB/sec)
>  >>> download performance with an Apache server on Windows and a Solaris
>  >>> client? [Is there a counter-example to prove that this poor
>  >>> performance is not always true of this combination -- without
>  >>> cranking the ack interval to unreal values, that is.]
>  >>>
>  >> I'll try to get a simple test going from my laptop tomorrow.
>  >> can you tell me what solaris version/update you are running.
>  >> you are downloading a >single< large file right
>  >
>  >
>  >
>  >server: Windows 2000sp2, Apache 1.3.26 with mod_jk/1.1.0 and Tomcat
>  >3.2.4 (reproducible with all other Apache and Tomcat versions I've tried)
>  >file: dd if=/dev/urandom of=8mbfile bs=1 count=8000000
>  >
>  >where httpd.conf has
>  >
>  ><IfModule mod__jk.c>
>  >JkWorkersFiles "C:/tomcat/conf/workers.properties"
>  >JkMount /webapp/* ajp13
>  ></IfModule>
>  >
>  >
>  >client: SunOS 5.8 Generic_108528-15 sun4u sparc SUNW,Sun-Blade-1000
>  >test1: wget http://w2k/8mbfile == 80KB/s
>  >test2: wget http://w2k/webapp/8mbfile == 1MB/s
>  >
>  >client: Linux 2.4.18-3smp
>  >test1: wget http://w2k/8mbfile == 8MB/s
>  >test2: wget http://w2k/webapp/8mbfile == 1MB/s
> 



Mime
View raw message