httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Erenkrantz <jerenkra...@apache.org>
Subject Re: Thread-unsafe libraries in httpd-2.0
Date Thu, 15 Aug 2002 18:36:35 GMT
On Thu, Aug 15, 2002 at 07:57:02PM +0200, johannes m. richter wrote:
> 
> >But does PHP ask HTTPD to load PHP modules?  If not, PHP would need to do 
> >the same.
> 
> This is how I understood Ian's suggestion. That PHP asks its extensions 
> whether they're thread-safe or not. And PHP itself tells Apache whether it 
> - as a whole, i.e. including its extensions - is thread safe.

FWIW, this infrastructure is already present within httpd-2.0.

ap_mpm_query(AP_MPMQ_IS_THREADED, *foo);

if (foo != AP_MPMQ_NOT_SUPPORTED) {
  ...we have threads...
}

HTH.  -- justin

Mime
View raw message