httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Colm MacCárthaigh <colmm...@Redbrick.DCU.IE>
Subject 2.0.38-39 lockup problem ?
Date Wed, 19 Jun 2002 08:26:46 GMT

I havnt tracked down a cause yet, but this happens with the 2.0.38
tarball, the 2.0.39 one, and the current HEAD. I'm running Solaris
2.8 on sparc, 

colmmacc@prodigy (~) $ uname -a 
SunOS prodigy 5.8 Generic_108528-13 sun4u sparc SUNW,Ultra-4

it's a nice and beefy E450. I was running 2.0.36 with my patches for
mod_cgid and mod_include applied (now in 2.0.39) , no problems whatsoever,
I used:

./configure --prefix=/local/web \
--enable-ssl \
--with-ssl=/usr/local/ssl \
--enable-module=unique_id \
--enable-module=env \
--enable-mods-shared=MAX \
--enable-rewrite \
--enable-info --enable-proxy --enable-proxy-ftp --enable-proxy-http \
--enable-cgid \
--enable-suexec --with-suexec-caller=www --with-suexec-docroot=/local/web \
--with-mpm=worker \
--with-suexec-bin=/local/web/bin/suexec \
--with-suexec-logfile=/local/web/logs/suexec_log \
--with-suexec-userdir=public_html \
--with-suexec-uidmin=100 --with-suexec-gidmin=100 --with-suexec-umask=077


first of all, with worker:

Compiled in modules:
  core.c
  mod_access.c
  mod_auth.c
  mod_include.c
  mod_log_config.c
  mod_env.c
  mod_setenvif.c
  mod_proxy.c
  proxy_connect.c
  proxy_ftp.c
  proxy_http.c
  mod_ssl.c
  worker.c
  http_core.c
  mod_mime.c
  mod_status.c
  mod_autoindex.c
  mod_asis.c
  mod_info.c
  mod_suexec.c
  mod_cgid.c
  mod_negotiation.c
  mod_dir.c
  mod_imap.c
  mod_actions.c
  mod_userdir.c
  mod_alias.c
  mod_rewrite.c
  mod_so.c

load averages:  3.40,  3.47,  3.45                                                       
 07:19:47
217 processes: 177 sleeping, 2 running, 2 zombie, 34 stopped, 2 on cpu     
CPU states:  0.0% idle, 91.2% user,  8.8% kernel,  0.0% iowait,  0.0% swap
Memory: 2048M real, 31M free, 2009M swap in use, 1524M swap free

   PID USERNAME THR PRI NICE  SIZE   RES STATE    TIME    CPU COMMAND
 18978 www        5   0    0  474M  415M cpu/3   91:43 45.04% httpd
  9847 www        4   0    0 1126M  961M run    279:03 44.73% httpd

happened within a few hours of having it running, took a look in /proc/NNNN/fd
, it didnt have anything too big open, truss -p revealed a very quick stream of
brk()'s

in case it was a worker mpm problem, recompiled last night with prefork

Compiled in modules:
  core.c
  mod_access.c
  mod_auth.c
  mod_include.c
  mod_log_config.c
  mod_env.c
  mod_setenvif.c
  mod_proxy.c
  proxy_connect.c
  proxy_ftp.c
  proxy_http.c
  mod_ssl.c
  prefork.c
  http_core.c
  mod_mime.c
  mod_status.c
  mod_autoindex.c
  mod_asis.c
  mod_info.c
  mod_suexec.c
  mod_cgi.c
  mod_negotiation.c
  mod_dir.c
  mod_imap.c
  mod_actions.c
  mod_userdir.c
  mod_alias.c
  mod_rewrite.c
  mod_so.c

and :

load averages: 19.79, 21.14, 19.19                                                       01:43:00
291 processes: 229 sleeping, 19 running, 3 zombie, 38 stopped, 2 on cpu       
CPU states:  0.0% idle, 95.9% user,  4.1% kernel,  0.0% iowait,  0.0% swap
Memory: 2048M real, 729M free, 1126M swap in use, 2393M swap free

   PID USERNAME THR PRI NICE  SIZE   RES STATE    TIME    CPU COMMAND
 28884 www        3  22    0   52M   47M run      4:12  6.89% httpd
 17682 www        3  23    0   52M   47M run      4:12  6.57% httpd 
   511 www        3  22    0   52M   47M run      4:09  6.56% httpd
 29712 www        3  32    0   52M   48M cpu/1    4:16  6.50% httpd
 23149 www        3  23    0   52M   47M run      4:11  6.45% httpd
 26294 www        3  32    0   53M   48M run      4:16  6.42% httpd
   522 www        3  23    0   52M   47M run      4:13  6.41% httpd
   518 www        3  23    0   52M   47M run      4:13  6.38% httpd
 26313 www        3  32    0   53M   49M run      4:18  6.37% httpd
 29663 www        3  33    0   52M   47M run      4:10  6.35% httpd
   515 www        3  23    0   53M   48M run      4:19  6.34% httpd
   514 www        3  32    0   52M   47M run      4:13  6.33% httpd
   521 www        3  32    0   53M   47M run      4:15  6.17% httpd
   519 www        3  32    0   52M   47M run      4:14  6.07% httpd
   520 www        3  32    0   51M   46M run      4:08  6.07% httpd


once again, truss reveals a whole big pile of brk()'s, I wasnt around
to kill these, so I didnt to see much more.

So I'm now rebuilding without SSL, because I had some ssl related problems
months ago. But Just to make the list aware that there may be issues. Is
anyone else on Solaris seeing anything like this ? seems odd, 2.0.36 was
running without any problems at all. 

I don't think disabling ssl will fix it,  so I'm going to wait for it
again, and try and gather as much as I can. 

-- 
colmmacc@redbrick.dcu.ie        PubKey: colmmacc+pgp@redbrick.dcu.ie  
Web:                                 http://devnull.redbrick.dcu.ie/ 

Mime
View raw message