httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Havard" <bri...@kheldar.apana.org.au>
Subject Nasty configure behaviour
Date Thu, 16 May 2002 15:09:55 GMT
I've run into this on both OS/2 & linux now. If you have apache2 installed
in /usr/local/apache2 or the apache2/bin directory is PATHed, the
APR_FIND_APR autoconf macro finds that in preference to the version in
srclib/apr. If the former is an old version Apache's build fails. I had
2.0.36 installed & trying to build HEAD died because it couldn't find
apr_strmatch.h (the include paths were pointing to my 2.0.36 source).
Shouldn't the bundled apr/apr-util always be used first?

-- 
 ______________________________________________________________________________
 |  Brian Havard                 |  "He is not the messiah!                   |
 |  brianh@kheldar.apana.org.au  |  He's a very naughty boy!" - Life of Brian |
 ------------------------------------------------------------------------------


Mime
View raw message