httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Cutright <acutri...@borland.com>
Subject compile time issue
Date Fri, 24 May 2002 17:59:29 GMT
hi all,

my apologies if this is not the appropriate forum. i have two compile/
link issues. users@httpd.apache.org doesn't appear appropriate; most
folks there aren't discussing compiler or linker isssues.

mod_ssl.so doesn't seem to be linking the openssl libs, like lcrypto, so
ldd -r is reporting missing symbols and the server fails in attempts to
load the module at run time. i'm compiling 2.0.35 on a variety of
solaris boxes, using all/ only Sun tools for building and linking.
(/usr/ccs/bin, /opt/SUNWspro/, etc.).

while looking for the solution to that problem, i ran into another link
error. i'm consistently seeing problems with libtool:

/bin/sh /vobs/WEB/src/apache2/src/srclib/apr/libtool --silent
--mode=link cc  -g -mt -DNO_DBM_REWRITEMAP    -DSOLARIS2=6
-D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT    -I.
-I/vobs/WEB/src/apache2/src/os/unix
-I/vobs/WEB/src/apache2/src/server/mpm/worker
-I/vobs/WEB/src/apache2/src/modules/http
-I/vobs/WEB/src/apache2/src/modules/proxy
-I/vobs/WEB/src/apache2/src/include
-I/vobs/WEB/src/apache2/src/srclib/apr/include
-I/vobs/WEB/src/apache2/src/srclib/apr-util/include
-I/vobs/WEB/ssl_inst/include/openssl -I/vobs/WEB/ssl_inst/include
-I/vobs/WEB/src/apache2/src/modules/dav/main
-I/vobs/WEB/src/apache2/src/srclib/apr-util/include
-I/vobs/WEB/src/apache2/src/srclib/apr-util/xml/expat/lib
-export-dynamic -L/vobs/WEB/ssl_inst/lib -R/vobs/WEB/ssl_inst/lib   -o
httpd  modules.lo -L/vobs/WEB/ssl_inst/lib -R/vobs/WEB/ssl_inst/lib
modules/http/mod_http.la modules/mappers/mod_so.la
server/mpm/worker/libworker.la  server/libmain.la  os/unix/libos.la
/vobs/WEB/src/apache2/src/srclib/pcre/libpcre.la
/vobs/WEB/src/apache2/src/srclib/apr-util/libaprutil.la
/vobs/WEB/src/apache2/src/srclib/apr/libapr.la -lm -lsocket -lnsl
-lresolv -ldl -lssl -lcrypto
/vobs/WEB/src/apache2/src/srclib/apr-util/xml/expat/lib/libexpat.la
ild: calling ld to finish link -- (internal error) ranlib_library()
unexpected EL_UNINITIALIZED : modules/http/.libs/mod_http.al


has anyone seen this problem? i am poking at libtool, etc. to attempt to
solve this problem, but any help is greatly appreciated.

cheers,
andy


Mime
View raw message