httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marc G. Fournier" <scra...@hub.org>
Subject Re: Apache 2.0.36 w/ FreeBSD ... 'hangs' ...
Date Tue, 21 May 2002 13:12:17 GMT

Just tried the same config on a seperate FreeBSD machine ... both are
running 4.6-PRERELEASE right now, and the problem(s) are the same ...
connect, hang, kill server and page gets sent across then server goes down
...



On Tue, 21 May 2002, Marc G. Fournier wrote:

>
> Can't describe it much better then that ... I've got it compiled
> WITH_THREADS and MPM=worker ... starts fine, get a line in
> /var/log/httpd-error.log:
>
> [Tue May 21 10:01:47 2002] [notice] Digest: generating secret for digest authentication
...
> [Tue May 21 10:01:52 2002] [notice] Digest: done
> [Tue May 21 10:01:53 2002] [notice] Apache/2.0.36 (Unix) DAV/2 PHP/4.2.1 configured --
resuming normal operations
>
> But when I try to connect to the site in question, the connection just
> hangs there ... as soon as I do a 'stop' of the server, though, the page
> is sent and then httpd terminates ...
>
> I'm running with settings of:
>
> <IfModule worker.c>
> StartServers         1
> MaxClients         128
> MinSpareThreads      5
> MaxSpareThreads     15
> ThreadsPerChild     64
> MaxRequestsPerChild  0
> </IfModule>
>
> And am getting no errors that I can find ...
>
> ps shows:
>
> earth# ps aux | grep http
> root    78796  0.0  0.1  9764 6012  ??  SsJ  10:06AM   0:00.11 /usr/local/sbin/httpd
> nobody  78799  0.0  0.1  9268 4944  ??  SJ   10:06AM   0:00.01 /usr/local/sbin/httpd
> nobody  78825  0.0  0.2 15044 6640  ??  IJ   10:06AM   0:00.03 /usr/local/sbin/httpd
>
> Which I find kinda odd since I'm not getting that many hits, and told it
> to only start with one :(
>
> Thoughts as to what I should look at here?  I've even enabled the
> 'apache_runtime_status' file, and that appears to make no difference ...
>
>
>
>


Mime
View raw message