httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cliff Woolley <jwool...@virginia.edu>
Subject Re: cvs commit: httpd-2.0/server/mpm/worker worker.c fdqueue.c fdqueue.h
Date Sun, 28 Apr 2002 15:02:16 GMT
On Sun, 28 Apr 2002, Bill Stoddard wrote:

> I have no problem with using apr_palloc()/memset() in place of apr_pcalloc().

Do you have a problem with making apr_pcalloc() a macro?

> > > >   +    rv = apr_thread_mutex_unlock(queue_info->idlers_mutex);
> > > >   +    if (rv != APR_SUCCESS) {
> > > >   +        return rv;
> > > >   +    }
> > > >   +    return APR_SUCCESS;
> > > >   +}
> > >
> > > As I said before, simply "return rv;" works here.
> > Yeah, but this is much more readable.
> I disagree. I would rather see "return rv".

FWIW, I also prefer return rv.  Or even return apr_thread_mutex_unlock();.

--Cliff

--------------------------------------------------------------
   Cliff Woolley
   cliffwoolley@yahoo.com
   Charlottesville, VA



Mime
View raw message