httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cliff Woolley <>
Subject Re: cvs commit: httpd-2.0 STATUS
Date Fri, 26 Apr 2002 17:35:48 GMT
On 26 Apr 2002 wrote:

>   +
>   +    * The atomics code produces binaries that are not forward compatible
>   +      on Solaris (eg. Solaris 5.6 binaries can fail on older hardware
>   +      running on Solaris 7). (See APR's STATUS file.)

I don't see what the big deal is.  The compiler produces code that is just
as incompatible [assuming we got the configure checks right in APR].  For
instance, you wouldn't expect to run an i686 binary on an i386, even if
the i686 were for an older version of the OS.  Whether that binary uses
atomics or not, it doesn't matter: it's for a newer version of the
architecture.  Same thing here.

As long as our binaries specify which flavor of sparc they're built for,
I don't see the problem.

   Cliff Woolley
   Charlottesville, VA

View raw message