httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cliff Woolley <jwool...@virginia.edu>
Subject Re: Leader fails to compile
Date Sat, 20 Apr 2002 20:01:33 GMT
On Sat, 20 Apr 2002, Thom May wrote:

> In file included from /home/thom/httpd-clean/include/pcreposix.h:21,
>                  from /home/thom/httpd-clean/include/httpd.h:85,
>                                   from leader.c:99:
> /usr/include/stdlib.h:485: parse error before `;'

I have seen this as well.  And I just now successfully reproduced the
problem on Linux with gcc 2.95.3 (Thom tells me he's on linux with gcc
2.95.4 debian prerelease).  I tried it again with gcc 3.0.4 and it works
fine.  The trouble is this structure in stdlib.h:

struct drand48_data
  {
    unsigned short int __x[3];
    unsigned short int __old_x[3];
    unsigned short int __c;
    unsigned short int __init;
    unsigned long long int __a;
  };

It's the __init line that's getting fried.  It gets replaced with this by
cpp:

    unsigned short int __attribute__ ((__section__ (".text.init"))) ;

This is the same thing I saw on apr's testatomic.  In that case I was
feeling lazy so I just changed the order of some includes and it worked.
But that's not really possible in this case.  Justin's calling it a gcc
bug, which I suppose it is... but there _must_ be some workaround.  I'll
try to find out what that is.

--Cliff



--------------------------------------------------------------
   Cliff Woolley
   cliffwoolley@yahoo.com
   Charlottesville, VA



Mime
View raw message