httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cliff Woolley <jwool...@virginia.edu>
Subject SSLProxy
Date Fri, 12 Apr 2002 03:43:52 GMT

I'm having trouble with the SSLProxy stuff as of a day or two ago.  With
ssl/proxy.t in httpd-test running under Linux 2.4 with prefork, all of
the tests are getting 403 response codes, eg:

#lwp request:
#POST http://localhost:8536/eat_post HTTP/1.0
#User-Agent: libwww-perl/5.60
#Content-Length: 33792
#
#server response:
#HTTP/1.1 403 Forbidden
#Connection: close
#Date: Fri, 12 Apr 2002 03:21:33 GMT
#Server: Apache/2.0.36-dev (Unix) DAV/2 mod_ssl/2.0.36-dev OpenSSL/0.9.6c
#Content-Length: 210
#Content-Type: text/html; charset=iso-8859-1
#Client-Date: Fri, 12 Apr 2002 03:21:33 GMT
#Client-Peer: 127.0.0.1:8536
#Title: 403 Forbidden
#
# testing : length posted
# expected: '33792'
# received: '<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
# <html><head>
# <title>403 Forbidden</title>
# </head><body>
# <h1>Forbidden</h1>
# <p>You don\'t have permission to access /eat_post
# on this server.</p>
# </body></html>'
not ok 40

And then in the error_log:

[Thu Apr 11 23:21:36 2002] [debug] mod_proxy.c(464): Trying to run
scheme_handler
[Thu Apr 11 23:21:36 2002] [debug] mod_proxy.c(468): Neither CONNECT, HTTP
or FTP for /eat_post

Ideas?

Thanks,
Cliff

--------------------------------------------------------------
   Cliff Woolley
   cliffwoolley@yahoo.com
   Charlottesville, VA




Mime
View raw message