httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Havard" <bri...@kheldar.apana.org.au>
Subject RE: what replaced --activate-module?
Date Wed, 10 Apr 2002 12:23:21 GMT
On Tue, 9 Apr 2002 11:37:21 -0700 (PDT), Rasmus Lerdorf wrote:

>There is no static library support for PHP with Apache 2 at this point.
>ie. you can only build using --with-apxs2 (if you are lucky)

It's not actually that hard to do it manually. While trying to debug PHP
(results reported earlier) I made a fully static Apache+PHP by doing the
following:

- Make a normal Apache2 build.
- Build (but don't install) PHP using --with-apxs2
- edit modules.c,
  - add the declaration "extern module php4_module;"
  - add php4_module to the ap_prelinked_modules & ap_preloaded_modules
lists.
- edit build/config_vars.mk,
  - add the full path to libphp4.la to BUILTIN_LIBS
  - Add to EXTRA_LIBS any libraries in PHP's config_vars.mk:EXTRA_LIBS
- run make again for Apache2

Well, it sounds like a bit of work when spelt out but it seemed pretty easy
when I did it :)

-- 
 ______________________________________________________________________________
 |  Brian Havard                 |  "He is not the messiah!                   |
 |  brianh@kheldar.apana.org.au  |  He's a very naughty boy!" - Life of Brian |
 ------------------------------------------------------------------------------


Mime
View raw message