httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Magnus Määttä <n0v...@kiruna.se>
Subject Re: CVS doesn't compile (2.0.36-dev)
Date Fri, 12 Apr 2002 20:25:09 GMT
On 12 Apr 2002 16:09:36 -0400
Jeff Trawick <trawick@attglobal.net> wrote:

> Cliff Woolley <jwoolley@virginia.edu> writes:
> 
> > On 12 Apr 2002, Jeff Trawick wrote:
> > 
> > > > Using latest CVS version, just a couple of minutes old..
> > > >
> > > > /bin/sh /root/Apache/httpd-2.0/srclib/apr/libtool --silent --mode=compile
gcc -g -O2 -pthread   -DHAVE_CONFIG_H -DLINUX=2 -D_REENTRANT -D_XOPEN_SOURCE=500 -D_BSD_SOURCE
-D_SVID_SOURCE   -I../../include -I../../include/arch/unix -I../../include/arch/unix  -c dir.c
&& touch dir.lo
> > > > In file included from ../../include/apr_portable.h:73,
> > > >                  from dir.c:57:
> > > > ../../include/apr_thread_proc.h:655:26: "@" is not valid in #if expressions
> > >
> > > What are the few lines around 655 in your copy of the file?  My copy
> > > doesn't have "@" there.
> > 
> > 
> > What are the contents of apr.h [specifically, the few lines around the
> > definition of APR_HAVE_SIGWAIT]?  This is one of those problems where a
> > variable didn't get substituted correctly for some reason.
> 
> that must be it
> 
> > 
> > You re-ran configure, right?
> 
> since I changed configure.in, you'd need to
> 
>   make extraclean
>   ./buildconf
>   ./configure
>   make
> 
> right?
> 

I'll try that..
Going to get drunk now.. bbl

> -- 
> Jeff Trawick | trawick@attglobal.net
> Born in Roswell... married an alien...
> 

Mime
View raw message