httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Erenkrantz <jerenkra...@apache.org>
Subject Re: 2.0.35 for Darwin was Re: where to describe critical OS-specific requirements
Date Tue, 09 Apr 2002 07:13:59 GMT
On Tue, Apr 09, 2002 at 02:55:34AM -0400, Cliff Woolley wrote:
> But yeah, I'm starting to get the feeling that this could escalate out of
> control.  When it was just one stray platform, it was one thing.  And
> especially since Aaron pointed out that the binary distributions already
> contain a presumably working libtool for that platform and everything that
> user would need to rebuild from scratch on that platform.  So I'm starting
> to lean toward the "point-em-at-the-binbuild-distros" approach.

I think AIX can be handled with the "use libtool-1.4.2" approach.
That seems okay.  I believe a lot of the differences between 1.3.5
and 1.4.2 are because of AIX.  =)  So, I don't think it's a simple
patch to 1.3.5 on icarus, but Jeff would know...

For Darwin (OS X), there isn't any GNU version of libtool that works.
Asking the user to use libtool-1.4.2 with XYZ patch or patch their
Apple-provided libtool is beyond where I feel comfortable asking
our users to do for releases.  

The tarball is there.  It works here on OS X.  Do whatever you
want with it.  I don't use releases anyway.  =)  -- justin

Mime
View raw message